UX Error

Incident Report for Limbo Studios Inc

Update

We are continuing to work on a fix for this issue.
Posted Jun 21, 2022 - 03:29 CDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 07, 2022 - 01:46 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 20, 2022 - 01:52 CDT
This incident affects: Limbo Cash.